Umzug: fertitsch

MySQL oder Textpattern haben eine etwas seltsame Vorstellung davon, was UTF-8 ist  … Von daher geht’s hier mit Latin-1 weiter, nachdem ich ca. 8 Mal die Datenbank neu aufgespielt habe  … Geht alles? Sachdienliche Hinweise bitte an mich!

Ach übrigens: Das Blaue ist die Berichterstattung, das Rote ist der eigentliche Kampf von Klitschko gegen den anderen.

29 Kommentare

Gerrit

Auch die Kommentarfunktion muss getestet werden!

Andreas

scheint zu funktionieren … :-)

Gerrit

Mhh, mal gucken, wie das mit der Benachrichtigung geht!

Bing

Vielleicht ist ja schon beim Exportieren der Daten was schiefgelaufen … Äber jötzt schöints jö zümündöst zü fünktiönüren. Viele testweise Grüße

Markus Wulftange

Wenn nur ASCII-Zeichen verwendet werden, gibt es zwischen Latin-1 und UTF-8 auch keinen Unterschied.

Gerrit

Bitte liebes Textpattern, schick mir ne Mail!!

Gerrit

Dankesehr :-)

@Markus: Aber ich habe natürlich Umlaute, sonst wird das schwer mit deutschen Texten ;-)

Christian

Problem hatte ich mit meinem TXP bisher zum Glück noch nicht, aber ich glaube es kommt einfach darauf an, welchen Zeichensatz der SQL-»Server« als Standard definiert hat. Ob UTF-8 oder Latin 1 sollte jedoch bei TXP keine Rolle spielen, aber dazu kennen wir deine Serverkonfiguration zu wenig :)

Eric

Das kann manchmal eine ganzschön hässliche Angelegenheit sein, mit den Zeichensätzen bei den MySQL-Datenbänken. Hatte damit auch schon Probleme, kann aber nicht sagen, ob das jetzt an TXP liegt oder nicht.

Jan

Meist liegt es schon am Export der Daten. Schön erklärt ist das alles hier: http://www.mysqldumper.de/board/viewtopic.php?t=2313

(Die verlinkte Textile-Seite kapier ich übrigens nicht, deshalb nicht als Link)

Oliver Olomodaßoboli

Etwas OT:
Kann mir mal jemand verklickern, was mir der Klick auf den Link »Kommentartext gestalten mit Textile« (unterhalb der Kommentarbox) bringen soll? Da seh ich zwar, was man alles tolles damit formatieren können soll, aber die wichtigen Shortcuts dafür werden eben gerade NICHT angezeigt …
(verwende FF 2.0.0.2, WinXP)
Grüße

Perun

Hi Oliver,

das Problem habe ich auch bei mir (in allen Browsern: SeaMonkey 1.1, FF 2.0.0.2, IE). Es wird das Ergebnis der Formatierung gezeigt, aber nicht wie die Formatierung ausschauen sollte.

Gerrit

So, das Textile-Ptolem ist nun auch behoben!

Retrax

Wie hast Du das Textile-Hilfe Problem gelöst?

Gerrit

Ich habe manuell eine HTML-Datei angelegt :-)

Anne

Hmm … ist der rote Teil nicht ein bisschen lang?

Elias

Habe den Kampf nicht gesehen, weis nur es muss nicht lange gedauert haben. ;)

Retrax

Kommt eigentlich noch eine Textpattern 4.0x Version bevor dann 4.1 released wird? Und weiß man schon bis wann die kommen soll?

Oliver Olomodaßoboli

Et jeht – is ja fantastisch! ;-)

@Dirk: Ich glaub, die Textile-Hilfe, die man von hier aus aufrufen konnte, hat noch nie (richtig) funktioniert ;-)

Gerrit

Die Textile-Hilfe hat selbstverständlich mal funktioniert, denn sonst hätte ich sie ja dereinst nicht eingebunden!

Kilian

Geht prima. Allerdings hatte ich auch schon solche Schoten, das ging irgendwie so, daß die Default-Encoding für neue SQL Datenbanken auf irgendso was obskur-nordeuropäisches eingestellt war (ohne, daß ich es merkte), WordPress aber fröhlich UTF-8 einträge zu sichern glaubte. Irgendwie hat das alles geklappt, aber als ich die DB sicherte und mit einer neuen Installation von WP einrichten wollte, war alles völlig vermatscht. Ich hatte auch keine Chance, da noch irgendwas zu retten …

macx

Wenn du MySQL >= 4.1 hast, ist echtes Zeichenencoding erst möglich. Da sagst du der Datenbank, dass sie UTF-8 ist, dann klappt auch der Import. Hast du eine ältere Datenbank oder die Datenbank ist als ISO deklariert, wirst du UTF-8-Daten nie importieren können. Da lag also dein Fehler.
Deine Grafik zum Boxkampf stimmt im Verhältnis so nicht, du hast sicher nur die Hälfte der Sendung gesehen. ;-)

Martin Hiegl

Wenn die DB bisher kein UTF8 ist, dann musst du sie einfach exportieren, in Eclipse die SQL-Datei öffnen und in das Encoding auf UTF8 setzen, alle Umlaute und Sonderzeichen mit Search&Replace ersetzen, sowie bei den Tabellendeklarationen Latin1 durch UTF8 ersetzen und schwups, haste damit alles auf UTF8. Hab ich am WE gemacht ;-)

Gerrit

@Martin: Exakt das habe ich auch zunächst gemacht (Mit Textwrangler statt Eclipse, ist aber egal). Alles hervorragend, auch in phpMyAdmin wurden die Umlaute gut angezeigt. Aber dann hat sich das mit Textpattern nicht vertragen. Wahrscheinlich muss man in Textpattern noch die Datenbankverbindung als UTF-8 deklarieren, aber ich weiß nicht, wo das geschieht!

Dentaku

Encoding ist immer ein Graus.
(kann es sein, daß oben und unten noch Debugausgaben kleben? Im Moment »68a2« bzw. »0«)

Kommentar verfassen

Mit dem Absenden dieses Formulars erklären Sie sich damit einverstanden, dass ich die von Ihnen eingegeben Daten auf meinem Webserver speichere. Ihr Name, der Kommentartext und die angegeben Website werden für die anderen Besucher von praegnanz.de angezeigt. Ich gebe jedoch insbesondere Ihre E-Mail-Adresse nicht an Dritte weiter und nutze diese auch nicht zu Marketing- oder Statistik-Zwecken. Sie können alle Daten zu einem späteren Zeitpunkt wieder entfernen lassen.